Scion tC Forums banner
1 - 16 of 16 Posts

·
Registered
Joined
·
78 Posts
Discussion Starter · #1 ·
Just put in my K&N CAI. Nice sound, really not that much difference in performance. I have a question about the Vacuum Switching Valve. In Idle position, this part make a ticking noise. When I give the car gas, it stops and then it comes back on once in idle for a few seconds. I don't know if it always did this when the stock intake system was in. I just want to make sure this is normal? If this is not normal does anyone know how to stop it? Please help.

P.S. Yes, I did a search already and found nothing.

FLaVaZ
 

·
Former '05er
Joined
·
12,467 Posts
It's working as designed. Relax, it's fine.
 

·
Former '05er
Joined
·
12,467 Posts
Yes, I've heard many VSVs tick. This one controls evaporative emissions purge and cycles when you are at idle. Did you attach it to something metal?
 

·
Registered
Joined
·
78 Posts
Discussion Starter · #5 ·
Originally posted by lo bux racer@Jan 8 2006, 05:16 PM
Yes, I've heard many VSVs tick. This one controls evaporative emissions purge and cycles when you are at idle. Did you attach it to something metal?
Yes. The directions said to bolt it to a peice that comes out of the intake pipe so it stays in place. And the intake pipe is metal. Whats with that?
 

·
Former '05er
Joined
·
12,467 Posts
It's amplifying the noise. VSVs are usually rubber mounted to isolate them from anything that will amplify the sound they make. That's why you're hearing it now, and didn't hear it before.
 

·
Registered
Joined
·
351 Posts
I'm having the same problem...So, Lance, You are saying that if we isolate it using some piece of rubber it is going to help, right?
Thanks.
 

·
Former '05er
Joined
·
12,467 Posts
Yep. It was mounted to a rubber piece in the beginning, that's why you couldn't hear it. Now it's beating on a metal plate, and it's noisy.
 

·
Registered
Joined
·
351 Posts
Originally posted by Tecrun19@Jan 16 2006, 08:27 AM
OMG ive been wondering what the hell that sound was. I have a Weapon R intake so i dont have any metal peice to connect it to, any ideas ?
Weapon R isn't made of metal?
 

·
Registered
Joined
·
47 Posts
well it is but i mean like all the other intakes have a little part on the pipe that sticks out so you can clip the eva thing to them. With the Weapon R there is no such part.

Here is a pic of Schubs intake and you can clearly see the little metal black piece sticking out. I dont have that so what do I do ?


Schubs intake
 

·
Registered
Joined
·
351 Posts
Still confused... But anyway try to isolate the "eva thing"
of whatever
it is connected using a rubber washer. It may help.
In my case it just reduced the noise so my next step is wrapping it around.

PS. Read Eddie's post
 
1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top