Scion tC Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey guys! my 2011 TC has a rough idle when I come to a stop and rpms sometimes drop below 500 and shakes the car a bit. I bought it in April with 87k miles on it. I changed the spark plugs a few months ago and have cleaned the throttle body and MAF sensor twice. the spray cleaning seams to help the situation but ultimately would come back after a few days. So far it hasn't tripped up a check engine light so I don't know what it could be. I was thinking about taking it to a mechanic so they can run through the live data to diagnose the issue but I'm pretty cheap living in NY where I don't feel like being scammed by a dishonest mechanic lol. I've read it could be a bad PCV valve, O2 sensor, or MAF sensor but before I decide, Id love to get some advice from yawl. The problem seams common enough but cant find a consistent fix. Id really appreciate the help. THANKS! :)
 

·
Registered
Joined
·
2 Posts
Hey guys! my 2011 TC has a rough idle when I come to a stop and rpms sometimes drop below 500 and shakes the car a bit. I bought it in April with 87k miles on it. I changed the spark plugs a few months ago and have cleaned the throttle body and MAF sensor twice. the spray cleaning seams to help the situation but ultimately would come back after a few days. So far it hasn't tripped up a check engine light so I don't know what it could be. I was thinking about taking it to a mechanic so they can run through the live data to diagnose the issue but I'm pretty cheap living in NY where I don't feel like being scammed by a dishonest mechanic lol. I've read it could be a bad PCV valve, O2 sensor, or MAF sensor but before I decide, Id love to get some advice from yawl. The problem seams common enough but cant find a consistent fix. Id really appreciate the help. THANKS! :)
I have the exact same problem, i also have a. 2011, havent found fix yet, but things I have tried already so you dont waste ur money, is plugs,maf sensor, pcv valve, pcv hose unless its cracked mine wasn't.
I had the chance to speak to scotty kilmer, he told me the best advice he could give me was to do a vaccum leak test, you could do yourself for super cheap and if no leaks, then it most likely is dirty or bad fuel injectors. Heres a vid of a super cheap Way of cleaning injectors without removal,
I have not done these last two things yet, but i will certainly try it out when I have time, but please let me know if it helps.
 
1 - 3 of 3 Posts
Top