Scion tC Forums banner
1 - 19 of 19 Posts

·
Registered
Joined
·
445 Posts
Discussion Starter · #1 ·
Just got my leds installed...just one more step towards everything being blue...



 

·
Registered
Joined
·
445 Posts
Discussion Starter · #4 ·
dont know...but neither is speeding...so oh well...i dont drive with just them on at night...and you cant even tell that they are on when the headlights are on...just daytime lights really...but its cool when im chillin in the parking lot and i got them on...every1 likes them...plus it matches the interior so well...
 

·
Registered
Joined
·
4,964 Posts
He probably put in the PIAA High Intensity LED's. Fiream has 'em.
 

·
Registered
Joined
·
6,586 Posts
I have been driving around with blue LEDs in my parking lights for over a year and haven't been hassled. They're not legal anywhere, but as long as you don't drive around with just the parking lights on, you'll probably be fine.
 

·
Registered
Joined
·
445 Posts
Discussion Starter · #11 ·
got mine from superbrightleds.com...the 4 LED ones...didnt want any over heating problems
 

·
Registered
Joined
·
119 Posts
u better be careful...I had the same leds and after about 3 months...they melted and went out
 

·
Registered
Joined
·
119 Posts
yea i guess so...i was running luminics ultra whites with them..but i put the stock low beams back in cuz one of the luminics bulbs burned out. SO i bought another pair of leds haha...we'll see if these last
 

·
Registered
Joined
·
71 Posts
funny - i bought the white 6 LED's from superbrightled's for my parking lights... they looked great (white/blueish) and also had the luminics Hyper Whites for lows and highs. After about a month, my driver side low-beam luminic blew, so i replaced it. About 2 weeks later, the passenger side low-beam luminic blew. Replaced that. I had to replace both again over time... so at this point, i've been thru 2 separate pairs of low beam luminics. I decided to remove the superbright led's and reinstall my original parking lights. As i was driving to work this morning i noticed my driver side low-beam luminic was blown again. WTF??? I'm wondering if it was because that bulb was at one point running with the superbright LED parking lights before i changed back to factory parking lights. Also, i'm wondering what the correct factory parking lights are supposed to be. On this forum in the info section, it states 194's... however, autozone told me 168's. So, i have 168's in there and i'm wondering if that is also causing a problem 168's and 194's look exactly the same to me... is there a difference???
 

·
Registered
Joined
·
119 Posts
i dont know for sure but when i bout my led's there wasnt any led's that were just 194 size.. they were 194/168..so that leads me to believe it might be the same. i could be wrong
 

·
Registered
Joined
·
119 Posts
Originally posted by phungy@Nov 28 2005, 10:09 AM
Good choice of JL sub
jls r nice i have nothin but good things to say about them
 
1 - 19 of 19 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top