Scion tC Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter · #1 ·
I know this has been answered before but I couldn't find it anywhere....I "tryed" installing my new CD player (HU) with the mounting kit from crutchfield but it wouldn't work, the peice that you have to pull off to get to the HU wouldn't fit back over the mounting kit and when I finally forced it over, the door the covers the HU would not close....What the hey?!....So I ended up dremeling the crap out of the mounting kit in attempts to get it to work....it didn't...I ordered a new kit, any pointer on what I can do? I never thought of flipping it over so the little cubby is on top, till after I thrashed it. anyways any pointers would be awsome
 

·
Registered
Joined
·
6,586 Posts
Your new HU is probably too deep. I also used the kit I got from Crutchfield, and it fit perfectly. Are you sure that the HU is bolted as far back as is possible? By the way, I have mine installed with the pocket on the bottom, so I don't think that's your problem.
 

·
Registered
Joined
·
453 Posts
i had the smae problem, on paper the mounting kit seemed like it would be perfect....when i went to pu tit in....it wasnt....the little tabs on the sides of the kit wouldnt allow me to insert the deck.....tried it upside down and right side up, no luck....i just ripped the two sides off the mounting kit (leaving the pocket and face plate area)...and then used the factory mounting bracket to connect my new head unit to....keep in mind this takes a alot of patience and a lot of adjusting...

im not sure why some cruchfield orders are working while others are not...i got mine only about a month ago and when it was delivered it said "xa & xb kit", i just assumed being that they didnt have install info on the car yet, that most likely the same kit was used for all scionms and they simply hadnt made a new wrapper for it......either way it seemed like it was close the whole time but never really fit the way i wanted....so i just gave up....and used my own way...
btw drilling the holes myself allowed my to push back the headunit a lot so the screen is completely flush with the rest of the mounting kit, only thing protruding is the volume knob, and it looks amazing....the first compliment i get on my car when people see it, bneside the car itself, is for the install....

in the end, it may take more time and effort, but drilling you own holes in the factory bracket, my be beneficial.....

here is some dudes write up on the whole thing from scion life...IMO his final look is terrible, but it gives you a visual of what i was explaining

HU Install

any more questions, let us know
 

·
Registered
Joined
·
131 Posts
Eastside you might check and see if you have to cut the xa and xb tabs off. When I installed my kit I did a test fit and noticed the kit was not tc specific. There were little tabs for the xa and xb on it. If you cut the tabs off it should fit. Just make sure the the cubby is on the bottom and the big mounts point up like the stock mount. Also when you put the dash peice on remember to keep the door shut or it will not go back on.
 

·
Registered
Joined
·
24 Posts
I agree with KCkid, the Metra kit I got was made for the XA, XB, and the TC. That drove me nuts too for a while until I decided to read the installation manual.(Yes, I'm guilty of not reading manuals like most people are)
That's when I found out I had to cut the other tabs meant for the XA and the XB and the whole thing finally fit. I could take the HU out again and take a picture of how the bracket looks like if you think that would help.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top