Scion tC Forums banner
1 - 14 of 14 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
As the title suggest I am looking for help into why my aftermarket radio blew the illumination portion of my dash. I checked the fuses and they were fine. The radio that I installed was a Sony explode model CDX-S2210, using an aftermarket wiring harness from a reputable dealer. During the installation I checked all wires more then once and am completely sure they were wired correctly. I brought the vehicle into my local dealership to ask them to see what was wrong. They were telling me that a ground wire within the dash had now become charged with positive power and it caused a short to occur which in turn blew a selonoid and the gauges were the clock is in the center console. In order to fix the problem they had to replace my entire gauge cluster. They blammed the problem on my radio and charged me $500 for repairs. I don't see how this is possible and am thinking there was a defect some place within the dash. I also think the dealership itself used the radio excuse so they wouldn't have to do the repairs under warranty. Has anyone else experienced any problems with the electrical within the dash?
 

·
Registered
Joined
·
4,694 Posts
1. Put stock HU back and take to another dealer.
if 1 does not work
2. If all you need to replace is gauge cluster - get one from the junk yard.

P.S. I guess it Xploded
Sorry. Couldn't hold it.
 

·
Registered
Joined
·
40 Posts
Discussion Starter · #5 ·
Yeah. If it didnt have them fix it then ANYTHING electrical would of been voided in the car from there forward till ti was approved again. From what they said it was a fuckup in the harness. Now I checked all the connectors and I matched all colors, I called the place I got it from and they make there own and they said if it is a defect on there end then they will pay for the damage supposedly. I am figuring that is a half the battle kinda deal cause you know they will not part with that cash easly. another main concern is, is there any wiring harness that I can use without having to worry about this again?
 

·
Registered
Joined
·
453 Posts
crutchfield ($9.99, i got mine there and its exactly what u need)
this is what u want, directly form my order history
....i would put my life on them....personally i think u should replace anyhting with the sony name on it that has to do with car audio...IMO

for the price thier quality is horrid, again IMO...but my buddy had a year old sony xplode deck in his audi that he bought form some dude, he went through one 1000 watt amp and two l7 solobarics before he was able to fingure out that his ####ty deck was the reason for all of his problems, and it WAS hooked up correctly....
 

·
Registered
Joined
·
453 Posts
sorry if the tone of that comes off hostile, when i see "Sony" mentioned in the same post as "problem", i just get excited, i have heard of this happening to a lot of people....i know that some people have never had a problem with thier sony decks...

i thinks its too bad that companies like sony are immediately expected to be quality, and i honestly believe that big successful companies like sony take advantage of this fact.

back to your point, which was the harness and not the deck, crutchfield is the way to go.....and i doubt that anyone will disagree wiht that....

thank you for allowing me to vent

and i love my PS2...
 

·
Former '05er
Joined
·
12,467 Posts
I had a long talk with the service guy about Sony car stereo when I was getting my Alpine face unit fixed (I dropped it really hard and it needed some serious work). He said Sony makes the worst product AND has the worst warranty service. From someone working in a place where they sell Sony (and Alpine) it was hard to ignore. This was in '93. I don't think it has changed at all.
 

·
Registered
Joined
·
453 Posts
amen...
 

·
Registered
Joined
·
1,866 Posts
Get yourself a clarion head unit with touch screen, thats what I have at least



Yeah I know its awesome and I love the functionality of Clarion ever since my Accord, and I will also go Clarion from here on out.
 

·
Registered
Joined
·
186 Posts
The same thing happened to me when I installed my XM Commander-- I tapped into the harness for power and for the ground, but for the ground I accidently tapped into the dimmer wire (which acts like a ground when the lights are off, but becomes positive when the lights are on). Anyway, I ended up frying my Commander and the gauge and some of the lights on the center dash console went out too. However, I found out that I just blew the fuse for the gauges--so I replaced the fuse and it's all good now. Maybe you should recheck them?
 

·
Registered
Joined
·
59 Posts
sony doesn't make bad car audio products, they just overrate some of their stuff, their head units and amps are solid, their subs on the other hand.. aren't really that great

also that one comment above was surprising, sony made better decks in the past, their recent decks are the ones that get even the slightest complaints

im pretty sure most of you are just jumping on the "sony bashing" bandwagon, i use alot of sony products, even some car audio, and everything was solid except the subwoofers
 

·
Former '05er
Joined
·
12,467 Posts
Sorry, I own a lot of Sony gear for other things, and I'm perfectly happy with it. I have friends with personal experience with Sony car audio. It is second rate at best, and not as reliable as many others. I have bought Sony TVs for years with excellent results, and I've even used some of their computer gear, it's not bad despite being overpriced (IMHO). I'm not bashing Sony, I'm reporting my experience and the experience of a number of friends.
 

·
Registered
Joined
·
453 Posts
same here, i have sony home audio, its great and well worth the money, their speakers, both car and home, suck testicles....

i think that for the money there is much better out there than Sony...again totally my opinion
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top