Scion tC Forums banner
1 - 20 of 34 Posts

·
Registered
Joined
·
164 Posts
Discussion Starter · #1 ·
Just got home from picking the car up! Rides quite nice so far...we'll see after they settle in! I'll also post pics tonight of the LED kit under the car as well once its dark out.


 

·
Registered
Joined
·
1,685 Posts
What springs did you put on? That looks exactly like the drop I want for my car.

-Eric
 

·
Registered
Joined
·
164 Posts
Discussion Starter · #4 ·
They're the TRD springs...they haven't settled obviously yet since they've only been on for about 2 hrs now...
 

·
Registered
Joined
·
1,860 Posts
anyway yeah the trds that I had on settled just about a quarter of an inch more after I had them on...they were pretty well sat by the time I had them on but it seemed a ton lower than what trd says though...but its cool anyway
 

·
Registered
Joined
·
164 Posts
Discussion Starter · #12 ·
Odd...wonder why it isn't loading up on anyone elses comps? Works fine here
 

·
Registered
Joined
·
533 Posts
wow I see it...its urmm...well let me think...oOOO.....

I cant see it either....
 

·
Registered
Joined
·
1,860 Posts
boosk your browser has most likely cached the image (if you are using internet explorer) as so you can see it all the time...clear your cache and you will see what we all see
 

·
Registered
Joined
·
164 Posts
Discussion Starter · #19 ·
Not using internet explorer...hmmm I think I know what happened tho...let me try this....
 

·
Registered
Joined
·
164 Posts
Discussion Starter · #20 ·
 
1 - 20 of 34 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top