Scion tC Forums banner
1 - 11 of 11 Posts

·
Registered
Joined
·
868 Posts
Discussion Starter · #1 ·
I didn't want to post this in the Member Pics area, simply because I'm not proud of these pictures. As many of you know, I've had a few problems with my car, most of which are not my fault, but this one was


Anyway, I never had the heart or stomach to take pictures of the aftermath of my first, and hopefully only accdient I had last month on the 26th of October. Here are the pictures I dug up that my Insurrance adjuster from geico took:









And here are pictures I took this morning before going to work, with her fully restored! I also included a couple of sad pictures I took at work. Sad because of the weather, lol. I HATE THE SNOW!!!









And if you really want to know what it feels like up here in NY... just watch this:
http://lindhome.com/photos/11-19-05/MVI_2114.avi

I think the body shop I took my car to (Nick Orso's if anyone is from around up here and wants to know) did a fantastic job. It took them 6 business days to fix her. I hope nothing like this ever happens again.
 

·
Registered
Joined
·
5,192 Posts
Wtf, how is it that where you are is like the Tundra compared to where I am?!

-Ed
 

·
Registered
Joined
·
4,964 Posts
Looks good as new.... and they get hit hard over in the west part of NY.... it's all that Lake Effect snow..
 

·
Registered
Joined
·
868 Posts
Discussion Starter · #8 ·
Yep, here in Syracuse (the middle of central NY), we get a TON of snow because of all the lakes. Cold air from canada hits our warm lakes and BAM, tons of snow.

I thought it was a little early for the snow this year, that's why I took the pictures late that evening at work, and the video. I just happened to have my camera in the car.

I mean, I like the snow somewhat, but we get it up here for SIX MONTHS!!
 

·
Registered
Joined
·
197 Posts
the pics with the car in the snow are pretty cool
 
1 - 11 of 11 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top