Scion tC Forums banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hey all! I have a 2007 Manual TC w/ a little over 165k miles on it. Up until the past couple of months I have never had any issues with this thing! I have had rough idle for a while and recently popped a CEL w/ P0505 after replacing the throttle body. I’m looking for advice on how to fix this... Is there a way to reprogram/reset the throttle body reset besides unplugging battery to relearn idle?

Things I have done are as followed over a 6 month span,
  • replaced alternator (autozone said I had voltage dips)
  • replaced battery
  • replace PCV valve & hose
  • cleaned MAF sensor
  • cleaned original throttle body
  • changed spark plugs
  • put in new throttle body (this is where CEL popped & unfortunately already had the original throttle body trashed)
  • purchased 2 more throttle bodies to see if I was just unlucky... No luck.
  • replaced vacuum lines from TB to intake manifold & from TB to vapor canister
  • replaced aftermarket cold air intake back to stock intake
  • checked electric connection to TB for connections/splits/etc.
  • sprayed the vacuum lines to check for leaks with no luck.

Whenever I reset the CEL it comes back within 5 mins..

Also have a small coolant leak that I have yet to diagnose… continue to have to top off the fluid every 2 months or so.. not sure if it’s related but I know that the coolant lines run through the TB.

Anyone had this issue and have any other suggestions? Anything would help… I’ve been battling the rough idle for too long and I'm not sure what more I can do 😫

Thank you!!
 
1 - 1 of 1 Posts
Top