Common Problems - Scion tC Forums
User Tag List

Reply
 
LinkBack Thread Tools
post #1 of 15 (permalink) Old 11-02-2011, 07:53 AM Thread Starter
Newbie
 
Join Date: Oct 2011
Posts: 4
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default Common Problems

What are some common problems with tC's? The one I'm going to be buying is a 2010 tC with 39k miles on it...rents say it's no good cause it's not under warranty anymore from manufacturer. Any suggestions?

Thanks!
FuturisticPotato is offline  
Sponsored Links
Advertisement
 
post #2 of 15 (permalink) Old 11-02-2011, 04:38 PM
tC Freak
 
jayny32's Avatar
 
Join Date: Jun 2011
Location: Haverhill, MA
Posts: 345
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Default

my moon roof squeaks when its open lol and in the winter my dash brake light for my e-brake comes on and off lol but those are my 08 tc problems we all may have dif problems. you should be fine, esp at 39k miles. scion is made by toyota, pretty reliable


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jayny32 is offline  
post #3 of 15 (permalink) Old 11-02-2011, 05:16 PM
Ignorance-intolerant
 
Candlejack13's Avatar
 
Join Date: Jul 2009
Location: Monroe, MI
Posts: 7,694
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Search the forum. This question has been answered plenty of times.
It's a toyota so it'll run forever. Keep up with your scheduled maintenance and youll be fine. I'm at 80k with just routine maintenance.

And Jay your brake light comes on because you need new pads or need to change your fluid/add some.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<<Click for old tC Pic Thread
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Candlejack13 is offline  
 
post #4 of 15 (permalink) Old 11-04-2011, 01:38 AM
Scion Guru
 
RS1#2047's Avatar
 
Join Date: Nov 2010
Location: Atlanta
Posts: 137
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Send a message via AIM to RS1#2047
Default

05 tC going strong with 88k+. Engine loves having the sh*t beaten out of it (masochistic bloody thing). If it's a manual, keep your revvs between 1.75-3k normal and 3-6k accelerating. One small issue, at least on my car, is if I dont give it enough revvs (like when i first started driving it) the carbon built up pretty fast in the throttle. Not a big deal, though because it's easily cleaned at a Toyota dealer for less than $200.

Quote:
lmao...what is going on here...we tell people to search and now its biteing us in the ace...
Quote:
Originally Posted by so lo
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
href="showthread.php?s=3d6e88085bf6c45fbdb23ae92d7ad196&p=1148105#post1148105" rel="nofollow">
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
your really shouldnt jerk while accelerating. theres a time and place for that. while driving is just too dangerous. or at least have your passenger help you out
real men drive stick
RS1#2047 is offline  
post #5 of 15 (permalink) Old 11-07-2011, 11:46 PM
Newbie
 
ramjv's Avatar
 
Join Date: Nov 2011
Location: bellflower california
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

mines just about 18k running swell its a 2010 model the car your getting is almost new
ramjv is offline  
post #6 of 15 (permalink) Old 11-08-2011, 02:00 AM
Scion Guru
 
c500129's Avatar
 
Join Date: Nov 2009
Location: Las Vegas, NV
Posts: 189
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I have a 2010 with around 33k miles. Main constant issue is AC on mine. brand new car bought in fall so no need for AC, then in summer realized it didnt work. schrader valve was broken. it was fixed but have had constant issues, sometimes it shuts off but starts when I put it on highest setting. Everytime I go to the dealer it works so they claim nothing is wrong with it.

Other than that I love the car.
c500129 is offline  
post #7 of 15 (permalink) Old 11-08-2011, 10:03 AM
Scion Guru
 
Join Date: Nov 2011
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

i bought my 07 with 53000 miles and as far as im aware, the only thing the guy has done is standard maintenance and there isnt a damn thing wrong. i have the squeaky clutch pedal but that seems to be the end of it.
leer0ybrown is offline  
post #8 of 15 (permalink) Old 11-08-2011, 04:52 PM
tC Freak
 
jayny32's Avatar
 
Join Date: Jun 2011
Location: Haverhill, MA
Posts: 345
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Garage
Default

Quote:
Originally Posted by leer0ybrown View Post
i bought my 07 with 53000 miles and as far as im aware, the only thing the guy has done is standard maintenance and there isnt a damn thing wrong. i have the squeaky clutch pedal but that seems to be the end of it.
my clutch squeaks too!! lol any way to get it to stop? it isnt bad or loud but you can hear it if you pay attention lol


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jayny32 is offline  
post #9 of 15 (permalink) Old 11-08-2011, 05:46 PM
Ignorance-intolerant
 
Candlejack13's Avatar
 
Join Date: Jul 2009
Location: Monroe, MI
Posts: 7,694
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Depends on where the squeak comes from. I've been meaning to get after mine that's coming from the shifter. You just have to open things up down there and put some grease in the right places.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<<Click for old tC Pic Thread
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Candlejack13 is offline  
post #10 of 15 (permalink) Old 11-08-2011, 07:51 PM
Scion Guru
 
Join Date: Nov 2011
Posts: 135
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

yeah my squeak is definitely coming from the clutch pedal area. it squeaks as i depress the pedal and almost sounds like a squeaky piston in a hydraulic pump.
leer0ybrown is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome