Air Bag Light On and No Horn? - Scion tC Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 08-14-2007, 01:52 AM Thread Starter
tC Freak
 
Jonnyb504's Avatar
 
Join Date: Oct 2006
Location: New Orleans, LA
Posts: 463
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to Jonnyb504
Default

I wired my mic for my navi in the silver panel on the steering wheel and I made sure I placed the wires just right to where they wouldnt get caught or anything. Well I had it in for atleast a month or two with no problems but then one day my steering wheel became hard to turn so I took it apart to find that the mic wire somehow came unsecured and got caught in the hub or something. I took it all out and it turns fine and all now but now I have the light and the horn doesn't work. I am assuming it has something to do with this since this started happening a few days after this issue. Any ideas? I read something about the clockspring...it was in a diffrent vehicle but I assume its the same?


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jonnyb504 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 08-14-2007, 09:54 AM
Destroyer of Cones
 
engifineer's Avatar
 
Join Date: Apr 2006
Location: Twin Cities, Minnesnowta
Posts: 7,057
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Default

There is a wiring problem in the wheel. You will need to remove it again and find the issues.

"I am not flipping you off. I just want to punch you in the face so bad that my fist has a boner"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
IIP Scion tC - STF Prepped
2001 Spa Yellow S2000 - STR Prepped
engifineer is offline  
post #3 of 6 (permalink) Old 08-14-2007, 01:08 PM Thread Starter
tC Freak
 
Jonnyb504's Avatar
 
Join Date: Oct 2006
Location: New Orleans, LA
Posts: 463
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to Jonnyb504
Default

I have done so and there was nothing that I could see wrong but I didnt see this so called spring so it coul be that...IDK


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Jonnyb504 is offline  
 
post #4 of 6 (permalink) Old 08-15-2007, 06:40 PM
Pick your own - you deserve it.
 
buderic's Avatar
 
Join Date: Nov 2005
Location: Indiana
Posts: 1,701
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Send a message via AIM to buderic
Default

Did you check the fuses? I doubt you blew anything or your air bag would have gone off but its possible. Easier to check than ripping your steering wheel out. Just an idea.

-Eric

The object of life's journey is not to arrive at the grave safely in a well preserved body, but rather to skid in sideways, totally worn out, shouting,
"What a Ride!!!"


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<---mr2slow
buderic is offline  
post #5 of 6 (permalink) Old 09-17-2007, 03:16 PM
Newbie
 
Join Date: May 2007
Posts: 17
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

Probably the clock spring is broke, it is behind the wheel. The air bag and horn wiring go through this, it is a black plastic housing. You must pull the wheel to R & R it but it's not too difficult.
mhen711 is offline  
post #6 of 6 (permalink) Old 01-30-2017, 11:59 PM
Newbie
 
Join Date: Jan 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Default

I have a Scion tC 05 I took my steering wheel off and I tried to put and aftermarket one but it didn't work so I tried putting my stock one back and for some reason my horn won't work and I have an air bag light on what can it be I need help do you guys think it's a fuse or something
Ohariliz chevere is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome